当前日期时间
当前时间:
网站标志
Logo
全站搜索
广告位
phpweb图片广告
广告位
phpweb图片广告
自定内容

phpweb已经是国内最强的的开源电子商务系统了,但并非完美,因为任何...

互联网3年一轮回,京东凡客等电商品牌在三年之前也不过是小打小闹,而如...

电商已经成为趋势,传统行业的竞争已经逐渐演变到网络上,也有不少用Weboss...

phpweb系统是固定的模式,适用于大部分行业与需求。但有一些行业还是有自己...

当前位置
文章正文

宝塔报错 Invalid version. The only valid version for X509Req is 0.

发表:管理员  发表时间:2023-11-23 10:12:50   阅读:(506)次  

宝塔报错:module 'cryptography.utils' has no attribute 'Enum'

点击右上角“修复”后,

宝塔面板申请ssl证书报错 Invalid version. The only valid version for X509Req is 0。

image.png

原因是由于服务器端使用了不兼容的 OpenSSL 版本导致的,服务器端的X509Req 版本只支持 0,而宝塔这边默认的版本为2。

我的是之前可以申请ssl,过一段时间申请就不行了,用的第一种方法解决的。

方法

目前有两种解决方案,当前为您采用的是第一种解决方案修复,目前已经可以成功申请证书,感谢您的理解与支持。


第一种

1、修改 /www/server/panel/class 下面的 acme_v2.py 文件

搜索找到 X509Req.set_version(2) 代码段 ,将其改为 X509Req.set_version(0)

image.png

2、清理宝塔面板缓存

3、重启宝塔面板服务

4、解决


第二种

服务器端升级对应的Openssl版本。(该方式升级前建议对服务器做一下快照备份,不推荐使用此方法)

1、终端依次运行如下命令:

btpip install pyOpenSSL==22.1.0

btpip install cffi==1.14

2、重启宝塔面板服务

3、解决

 

假如我们资讯/文章对您有所帮助,您可以通过扫描捐赠二维码支持一下我们~

感谢您对我们的支持,您的小小支持让我们有信心走得更远!

脚注信息
© 2005-2015 草莓互联(100cm.cn) 广州同福信息科技有限公司 版权所有,并保留所有权利。

广州市东莞庄一横路116号 粤ICP备11046216号

经营性网站备案信息 广州网络警察报警平台 不良信息举报中心  百度信誉档案 广州工商红盾网 可信网站认证